YOOtheme Pro is here! The best WordPress and Joomla theme. Learn more

Avatar timothy.gard asked

No Route Found for index...

I just updated my Widgetkit to the latest version (2.8.2) and I received the following message: "No Route found for Index" when I go to the Widgekit component.

No idea how to resolve this issue....

Tim

  • Joomla
  • Widgetkit
  • Unity

16 Answers

1

Avatar michael.maass Support answered

If you are using Joomla and get the error "No route found for index" when accessing the Components > Wigetkit it could be caused by a failed or incomplete installation.

Please try the following:

  • In the Joomla backend go to Extensions > Manage > Discover, and click on the button "Discover" in the toolbar.

  • Should there be a list with extensions which show "YOOtheme" in the column "Author",
    tick them all, and click on the button "Install" in the toolbar.

    Image

  • Go to Extensions > Manage, into the filter field enter widgetkit and click on the search icon.
    Tick the disabled ones, and lick on the button "Enable" in the toolbar.

    Image

    The "K2" or "ZOO" extensions are only required if you have K2 or ZOO installed. Otherwise leave them disabled.

Go to Components > Widgetkit to see if the "No route found ..." error message is gone.

Thank you

0

Avatar timothy.gard answered

Okay, we seem to have a small consensus that 2.8.2 of Widgetkit has caused some issues. I have since rolled back my site to a backup so that I could get some functionality back with Widgetkit.

Does anyone at Yootheme have an explanation for the above or at least a general idea to point us in the right direction? Could it be that I haven't updated my Joomla installation? That was another issue, unrelated to this issue.

Thanks in advance!

0

Avatar timothy.gard answered

Just upgraded to the latest Widgetkit (2.9.0). Same issue. And no responses for a solution....hmmm....

0

Avatar timothy.gard answered

Nope. Clearing my cache didn't help...I normally clear the cache on a regular basis anyway. Still no answers? I've updated everything else on the site, but I can't update Widgetkit because I keep getting the message indicated above....

0

Avatar adam.kelsven answered

The same error persists with version 2.9.1 (using latest Joomla).

Edited

0

Avatar webbytechy answered

Hi guys did anyone find a way of solving this No route found for "index" problem with Widgetkit 2? Any way to solve it other than rolling back to older version? Today i tried upgrading to 2.9.1 and everything which used Widgetkit on the front end of my website is now not visible.

Please help out if you solved this guys.

0

Avatar timothy.gard answered

Nope. Not solved. I remain at an earlier version of Widgetkit until I find an answer. And it doesn't seem an answer is forthcoming. This is the support area of Yootheme, right? I even provided my login credentials in the first attempt for a resolution to this problem.

0

Avatar hankvanv answered

Not sure if this will help anyone but I noticed when I turned off Caching under Global Configuration then there was no issue. When I turned it back on the issue returned. Cleared cache... no luck. Had to change from "Memcached" to "File" for it to remain resolved. Not sure what the issue is but my site is back, so I'll work with it as is for now.

Know someone who can answer? Share a link to this question via email or twitter.