YOOtheme Pro is here! The best WordPress and Joomla theme. Learn more

Avatar danny.malouin asked

Invalid JSON UIKIT (Bug)

Hi

I get a bunch of Invalid JSON errors from my YTP template ?

uikit.min.js?v=1.3.2:3   

Invalid JSON:  

e._initProps @ uikit.min.js?v=1.3.2:3  
t.$mount @ uikit.min.js?v=1.3.2:3  
e._init @ uikit.min.js?v=1.3.2:3  
Tooltip @ VM6390:2  
(anonymous) @ uikit.min.js?v=1.3.2:3  
each @ jquery.min.js:2  
each @ jquery.min.js:2  
e.(anonymous function) @ uikit.min.js?v=1.3.2:3  
e.connect @ uikit.min.js?v=1.3.2:3  
o @ uikit.min.js?v=1.3.2:4  
o @ uikit.min.js?v=1.3.2:4  
o @ uikit.min.js?v=1.3.2:4  
o @ uikit.min.js?v=1.3.2:4  
o @ uikit.min.js?v=1.3.2:4  
o @ uikit.min.js?v=1.3.2:4  
o @ uikit.min.js?v=1.3.2:4  
o @ uikit.min.js?v=1.3.2:4  
o @ uikit.min.js?v=1.3.2:4  
o @ uikit.min.js?v=1.3.2:4  
(anonymous) @ uikit.min.js?v=1.3.2:4  
Qt.observe.childList @ uikit.min.js?v=1.3.2:4

Any thoughts what's causing this ?

  • UIkit
  • YOOtheme Pro

2 Answers

1

Avatar niall.sheehan answered

BUMP - Posted FEB 10 and still no answer.
We are also seeing this.

Invalid JSON.
e._getProps @ uikit.min.js:5 07:44:46.297 uikit.min.js:5

Site will not load if PHP 7.1 is used...trying to sort out why. If we disable Widgetkit PHP 7 is okay.

0

Avatar maggus86 answered

I can remember that I have seen a similar error log in the console.

The problem was something like:

  • I have used UIkit with wrong jQuery selectors
  • I have used UIkit as a function when there shouldn't be a function (wrong declaration of variables)

Maybe this can help you finding the error!

Edited

Know someone who can answer? Share a link to this question via email or twitter.