YOOtheme Pro is here! The best WordPress and Joomla theme. Learn more

Avatar tom.vd.berg asked

Zoo Gallery problems

I have several problems with the gallery element

  1. Even when I set the auto play to ‘No’ the slides are still showing up one by one.
  2. The size of the main image is determined by width and number of the thumbnails
  3. It doesn't display the entire image in safari, only when resizing the browser window it shows up

TEST URL: http://www.onori.nl/product-zoo/category/equestre

<div class="zoo-gallery" id="08416e3c-059f-4f0c-bbb1-82b871d1c021-58e2ae0545bf5" data-widgetkit="slideshow" data-options="{animated:top,width:400px,height:400px,autoplay:0,interval:5000,duration:500}" style="position: relative; width: 310px;">

Joomla version: 3.6.5
Yootheme: Yoo_Dolce-Vita
Zoo version: 3.3.25

Best regards, Tom

see hidden information

Some progress??

  • Joomla
  • ZOO
  • General Question

Edited

4 Answers

0

Avatar hendrik Yootheme answered

Hi,

from what i can see on the website the autoplay option ist still activated in the widgetkit slideset:

data-uk-slideset="{autoplay: true ,default: 1}"

Please also update your Widgetkit installation, you've installed v2.7.1 and the current available version is 2.9.4.

The code example in your question shows a Widgetkit 1 slideset, which is not present on the page you have linked?

To investigate the issue further please provide a link to the actual page in question and also provide backend access.

UPDATE 24.04.2017
The behavior on the website is really odd. Once I open the frontend of your website the browser occupies 80 - 90% CPU usage.
Also, I found this chunk of code on your site, what is the purpose of it?

<script>    
UIkit.$win.on('resize', UIkit.Utils.debounce(function () {    
    UIkit.$('.zoo-gallery').slideshow();    
}, 100));    
</script>

UPDATE 28.04.2017
Okay, we've found the issue. The next update for ZOO will fix it, i expect it to be released early next week.

Edited

0

Avatar hendrik Yootheme answered

Hi,

unfortunately, the user you provided does not have access to the app configuration.

I have tested the ZOO gallery with slideshow enabled and autoplay disabled in a local installation and it does work without issue.
Do you have the gallery configured in the correct item type and the template that is selected for the app? There are three different templates available in ZOO ('default', 'uikit' and 'ukit3') you need to configure the gallery option in the one that is selected in your app.

Regards

0

Avatar tom.vd.berg answered

Yes, I selected the 'Default' template in the Product Catalog Config tab. That the one I configured.

You can see it is set to '0' in the source code.
Image

I have changed the rights of the user. Will you try again.

0

Avatar tom.vd.berg answered

Some progress??
Did't hear from you for 10 days.

Know someone who can answer? Share a link to this question via email or twitter.