YOOtheme Pro is here! The best WordPress and Joomla theme. Learn more

Avatar dominic.wilson.42 asked

Jack Baker Demo Install

Hi, is there anyway of providing Jack Baker demo package with the previous version of joomla and then I update? I cant get past the installation process because of the bug with 3.7.4 and want to install it :(

  • Joomla
  • General Question

7 Answers

0

Avatar hendrik Yootheme answered

Hi,

there are two ways to get around this bug.
First one is creating your own demo package with the Joomla 3.7.3 version. And the second one is installing the template only and then use the Library to download the available page layouts.

1:
Download the Joomla 3.7.3 Full Package and unzip it.
Copy the following files and folder from the YOOtheme demo package to the downloaded Joomla package:

/installation/localise.xml  
/installation/sql/mysql/sample_yootheme.sql  
/installation/language/\*/\*.ini  

/templates/yootheme/\*.\*

Now you can upload this package to your webserver and start the install routine. You will have the 'Install YOOtheme Demo Content' option available during the installation steps.

2:
You could also install an older Joomla 3.7.3 version and install the template only.
When you have setup the API key in the YOOtheme Installer plugin you can use the Layout Library to download the page layouts of any of the demo pages. Only will you have to manually create the pages/articles first.

We have decided against uploading a package with an older Joomla version because the amount of people affected by this bug is not the majority.

Regards

Edited

0

Avatar peter.russell.64 answered

Hi
This Joomla bug with 3.7.4 is frustrating. Does anyone have the revised database.php file that works?
Cheers Peter

0

Avatar dominic.wilson.42 answered

Agree, so frustrating. They clearly didnt test it properly (joomla not yoo)

0

Avatar dominic.wilson.42 answered

Hi, i went for option 1 and it installed all ok until when it finshed it came up saying delete installaton folder which i did and can login to administrator ok but on home page i get
500 - JHtml::render not found.
Any ideas?

0

Avatar dominic.wilson.42 answered

Fixed it, downloaded the jack baker template only again as it was asking for the framework, all working, great support thank you :)

Edited

0

Avatar peter.russell.64 answered

Hi
Thanks Hendrik, that worked. I think Yootheme should reconsider the bundling of J3.7.4 with the themes at the moment, very frustrating when you are trying to install quickly and for new members (not me) it will leave them with the wrong impression, even tho the issue is a Joomla one.
Cheers Peter

0

Avatar tomas.kulhanek answered

Hi,
I downloaded modified file database.php from Joomla GitHub and it works. There is some error that should be fixed in Joomla 3.8...

Just replace original file installation/model/database.php
with this https://ufile.io/ew9u5

Know someone who can answer? Share a link to this question via email or twitter.