YOOtheme Pro is here! The best WordPress and Joomla theme. Learn more

Avatar gekroon asked

Calendar Events Zoolanders stop to working after the update.

Hy guy sorry for this message but I have discovered a little problem of compatibility. In the last update I've solved it but now, with the yootheme_j3_1.10.3 , it still make me problems. I hope that this messages can help other persons with the same problem.

I use on my website Zoolanders Events App and the last version of your component Zoo and Yootheme Pro etc... The callendar has always worked well but in the last two updates it gives me problems.

When I've done the last update my callendar stoped to show me the events. Seems that the problems is in the line 200 of the file templates/yootheme/vendor/yootheme/theme/platforms/joomla/index.php

                } else {   
                    $this->document->addCustomTag("<script>try { {$custom} } catch (e) { console.error('Custom Theme JS Code: ', e); }</script>");  
                }  
            }

it want from the website only documentHtml but in the realty from the website arrive a documentRaw that doesn't support the addCustomTag.

I solved it simply with this

// my edit  
                } else { if(method_exists($this->document, 'addCustomTag'))  
                    $this->document->addCustomTag("<script>try { {$custom} } catch (e) { console.error('Custom Theme JS Code: ', e); }</script>");  
                }  
            }

I hope that this can help someone else and that you can add this edit in the next updates. Thanks

  • ZOO
  • Tutorial
  • YOOtheme Pro

2 Answers

1

Avatar michael.maass Support Online answered

I hope that this can help someone else and that you can add this edit in the next updates. Thanks

I passed this on to the developers for revision.

Thanks for reporting and sharing your findings

0

Avatar michael.maass Support Online answered

If your error message mentioned
Call to undefined method Jommla\CMS\Document\RawDocument::addCustomTag()
please try and update to YOOtheme Pro 1.10.4. It takes care of this issue.

Thank you

Edited

Know someone who can answer? Share a link to this question via email or twitter.