YOOtheme Pro is here! The best WordPress and Joomla theme. Learn more

Avatar michael.maass Support asked

[Tutorial] Using the Joomla "Multilanguage" feature with a Warp 7 template

Most important: The YOOtheme templates are fully compatible with the Multilanguage feature of Joomla.

There are some steps to consider when setting up a Joomla site with more than one language, though.

The basic configuration of the Joomla Multilanguage feature

The following steps are a basic part of the procedure to properly configure a Joomla CMS for the use with different languages:

  • In Extensions > Language Manager add a Joomla language "Xyish (xy-XY)" and properly configure it.

    To avoid misunderstandings: "Xyish (xy-XY)" is an entirely made-up example language name, of course. In your case it could be "Italian (it-IT)", "French (fr-FR)", or any other language.

  • In Menus add a "Main Menu (XY)" for the language xy-XY.

  • All menu items of this menu have to be set to Language > Xyish (XY).

  • 1 of the menu item has to be set to Default Page > Yes. If correctly configured it should show an icon with the language's flag in the column "Home".

  • In Extensions > Module Manager create a new module of the type "Menu" (or duplicate and existing one), set Module > Select Menu > Main Menu (XY), set it to Language > Xyish (XY), as well as Menu Assignment > Module Assignment > On all pages, and publish it in the position "menu".

  • Make sure the language's "Home" menu item points to a valid target, like a Joomla article set to Language > Xyish (XY).

Up to this point there is nothing special if you use a YOOtheme template. What you did would have to be done regardless of the template you use in the frontend.

Using Warp 7 "Layout Profiles" in your multilanguage site

Now if you started out with a full YOOtheme Joomla demo package the following situation might irritate you:

  • Your standard "Home" page which is still used from the demo content shows a certain styling, a full width "top-a" or "fullscreen" for instance.

  • But your added language's "Home" page shows a very different styling.

As opposed to what a user who is new to the concept of "layout profile" might readily assume: There certainly is no "bug" involved.

The different display is conforming to different layout profiles these pages (= menu items) are assigned to. The new language's "Home" menu item is just not completely configured yet, and probably use the layout profile named "default".

If you want two pages — like your standard "Home" menu item and the "Home" page of one or more languages — use the same styling make sure they are assigned to the same layout profile in the template's Layouts > [theProfile] > Assignment section.

In this fictitious case where you started out with a full demo installation proceed as follows:

  • Go to Extensions > Template Manager > yoo_TEMPLATE > Options > Layouts.

  • From the list of layout profiles select the one named "frontpage".

  • Scroll down to the section "Assignment".

  • In the list of menu items you will find a ticked Image Home_ menu item. This means it is assigned to the profile and will use its settings.

  • Look for your new language's "Home" menu item and also Image it.

  • Click "Save" in the toolbar.

Reload the page in the frontend and switch between the standard "Home" and the "Home" of your language.

The styling (colours, position dimensions, navbar, system output, etc.) should be the same now.

Needless to say: Depending on the language and the modules' settings only modules will show which are either set to Language > All or to the currently active language. But this is not related to the template but applies in general.

For more information about layout profiles and their assignment please carefully read the "[Tutorial] Warp 7: Understanding layout profiles".

Add the "offcanvas" menu for a new language

In order to have a main menu for your language at lower resolution as well, you have to publish a further module for the "offcanvas" menu:

  • Go to Extensions > Module Manager and look for the module showing your "Main Menu /XY)".

  • Duplicate this module and open the copy.

  • Leave everything as it is but set Position > offcanvas

  • Make sure to set Status > Published.

  • Click "Save & Close" in the toolbar.

Reload the page in the frontend, resize the browser window until you see the menu "toogler" for lower resolutions, and click on it. The "offcanvas" should show the main menu for the language "XY".

For further information also please read the "[Tutorial] The "mobile" menu and logo in a Warp 7 theme/template".


Some general hints regarding the configuration of Joomla's "Multilanguage" feature:

Mind that setting up the multi-language feature in Joomla requires utmost care and a structured approach.

Thoroughly read the available information and tutorials you can find on the specialised Joomla! sites. For example here in the Joomla documentation's Language Switcher Tutorial. There is also offer a PDF tutorial.
The following links might give you further insight. Some also explain the subject by showing a movie:

Generally these are the rules (quoted from the manual) for a site using the built in Joomla! Multilanguage feature:

Before putting the Multilanguage site online, check the following:

  1. Are the desired Content Languages published?

  2. Are the related Site Languages installed and activated?

  3. Are the Default Home Page menu items for each Content Language present and published?

  4. Are the Menu modules which display these Default Home Pages present and published?

  5. Is there a specific menu containing a Default Home Page menu item to which is assigned language "All" and its Menu module unpublished?

  6. Are the 'Language Switcher' modules present and published?

  7. Is the 'Language Filter' system plug-in activated?

Please understand that we can not provide detailed guidance about the Multilanguage feature in general. This can easily get very complex and is outside the scope of the YOOtheme support.

Where you feel unsure about anything related to the topic of using different languages in Joomla I recommend you ask your question here:

The Joomla Forum > Language – Joomla! 3.x

Thank you

  • Joomla
  • Tutorial

Edited

7 Answers

1

Avatar tobias.m Support answered

Hi Michael,

thanx for the good tutorial and your time. :-)

regards,
Tobias

0

Avatar michael.anlauf Support Online answered

Actually the fake menu with Home, languages all, doesn't need a module. You just have to create it first, set to Home, languages all, then you can set the Home pages in different languages also as Home page. You know you did it well when each Language Home page has the related Language flag.

0

Avatar michael.maass Support answered

Actually the fake menu with Home, languages all, doesn't need a module.

I meant to cover this in item number 5 of the "checklist" towards the end:

5 — Is there a specific menu containing a Default Home Page menu item to which is assigned language "All" and its Menu module unpublished?

To avoid misunderstandings: The "All" languages menu and its "Home" menu item is certainly not a "fake" but highly important. If it doesn't exist — is deleted or was never created — a visitor of the site might get a 404 error.

And leaving the "All" languages menu module there for testing and troubleshooting purposes is highly recommendable. So I suggested to just make sure it is unpublished.

You know you did it well when each Language Home page has the related Language flag.

Or as I phrased it toward the beginning of the tutorial:
"If correctly configured it should show an icon with the language's flag in the column 'Home'".

Thanks for the feedback

Edited

0

Avatar viperdriver answered

Hi,

I can't see to figure out how to do a language selector in the mobile menu. Can you advise?

0

Avatar michael.maass Support answered

I can't see to figure out how to do a language selector in the mobile menu. Can you advise?

Duplicate the existing "Language Switcher" module and publish this instance in the position "offcanvas".

Thank you

0

Avatar boggas answered

I have tried all steps, but still I only got one language on my page.
On the System - Language Filter I have Yes on Remove URL Language Code, but still the the language code dispalys.
What can be wrong?

www.kelpiegallery.se

Know someone who can answer? Share a link to this question via email or twitter.