YOOtheme Pro is here! The best WordPress and Joomla theme. Learn more

Avatar michael.maass Support asked

[Tutorial] 1-click updates for Widgetkit 2 or ZOO or YOOtheme Pro templates

In order to authenticate yourself while requesting the download without compromising your credentials, YOOtheme provides a personal API Key, which you will find in your YOOtheme account page. It acts on your behalf, so remember to treat it just like a password, don’t share it.

Image

To set the API Key copy it from your user account, then open the plugin "Installer - YOOtheme" in Joomla's Plugin Manager.

Image

Paste your API key into the field, and click "Save & Close" in the toolbar:

Image

Go to Extensions > Extension Manager > Update, click on "Find Updates", tick the extensions you want update, and click on "Update":

Image

Mind that depending on the security restrictions of your webserver it might not be possible to update this way. If it doesn't work:

  • Downloadt the most recent installer package from the YOOtheme download area.

    • For Widgetkit 2 update download the "Joomla 3.x Extension" package.

    • For a ZOO update download the "Joomla 3.x Extension + Apps" (no other one!)

  • Install it via Extensions > Extension Manager > Install > Upload Package File

Both approaches — 1-Click update or via the Joomla Extensions Manager — will result in an updated extension.

Important: At the time being YOOtheme templates/themes can not be updated via a "1-Click-Update".

Thank you

  • ZOO
  • Widgetkit
  • YOOtheme Pro

Edited

9 Answers

0

Avatar kayhan Support answered

Perfect, just needed and found information in this tutorial!

0

Avatar michas. answered

I dont see in my plugin-area as admin a installer-yootheme - Plugin ;-(

where i can find this???

Michael

0

Avatar michael.maass Support answered

@michas.

I dont see in my plugin-area as admin a installer-yootheme - Plugin ;-(

Where possible please stick to the terms used in the English version of Joomla. Otherwise there could be misunderstanding.

Look in Extensions > Plugin Manager as described above:

Image

Which YOOtheme product do you use? A template (which one), ZOO (which version), Widgetkit (which version)?

Please provide more details.

Thank you

0

Avatar robert.young.62 answered

I'm using the avion template and I also cannot find any plugin "Installer - YOOtheme" (or any similar name) in my installation.

0

Avatar michael.maass Support answered

I'm using the avion template and I also cannot find any plugin [...]

The "1-Click-Updater" does not update templates/theme but only Widgetkit 2 or ZOO.

Thank you

0

Avatar robert.young.62 answered

Thanks, you might like to review the thread title in that case.

0

Avatar michael.maass Support answered

Done. You are right. I mentioned the templates though they cannot be update this way.

Thanks for pointing out

0

Avatar christian.musuraca.95 answered

Hello,

I, too, do not see Installer - Yootheme in my Plug-in manager.

I have the latest ZOO version. 3.3.17

My question on this thread is...is it safe to update to Joomla 3.5.1 from 3.4.8?

Based on the above, but not applicable, but just in case: Lykka Theme

Thank you in advance!

Edited

0

Avatar pixelstext answered

How come that Widgetkit 2 cannot been updated in one click through Watchful.li dashboard? Watchful.li

Edited

Know someone who can answer? Share a link to this question via email or twitter.