YOOtheme Pro is here! The best WordPress and Joomla theme. Learn more

Avatar fabrice.de.comarmond asked

Avanti theme parallax banner behaving differently after widgetkit upgrade to 2.6.1 from 2.5.3

Hi,
I am having a problem after widgetkit 2.6.1 on a wordpress site autosizing of the parallax banner doesn't work properly. There is a background-size set in the element-style. If I get rid manualy of the background-size on the upgraded site I get the same image as the one on my site still using widgetkit 2.5.3 and it is behaving properly.
I would appreciate if one knows something about this upgrade. I am using wordpress and avanti theme.
On the site using widgetkit 2.5.3 I get the following element settings for the banner :
element.style { * 
 height: 430px; * 
 background-image: url("/media/banner-frontpage-top.png"); * 
 background-position: 50% -50.69px; * 
 background-repeat: no-repeat;
}
On the site upgraded with widgetkit 2.6.1 I have :
element.style { * 
 height: 430px; * 
 background-image: url("/media/banner-frontpage-top.png"); * 
 background-size: 1850px 982px; * 
 background-position: 50% -57.81px; * 
 background-repeat: no-repeat;
}
If I disable background-size the parallax top banner behaves OK.
Thanks for your help,
Fabrice

  • WordPress
  • Widgetkit
  • Avanti

Edited

10 Answers

0

Avatar rodolphe.billuart answered

Same problem here on Joomla 3 with Gusto Theme...
Since the upgrade it adds a background-size that is f**king up the view of the images...

0

Avatar maraike answered

Hello,

please add your website link and your login informations so I can investigate further. You can put both in the hidden informations so only I (and the yooteam) can see it. Just edit your original question and scroll down until you see the text area for the hidden informations. Thanks.

best regards

0

Avatar fabrice.de.comarmond answered

I added my sites infos with and without the widgetkit upgrade on my dev platform in the hidden field of my initial post.
Thanks for helping.
fabrice

0

Avatar maraike answered

Hello Fabrice,

sorry for the late reply, I will take a look at your problem and get back to you as soon as I know more.

best regards

EDIT The background size is there to make sure the image is large enough to show the parallax effect. You can open any graphic program (photoshop or gimp for example) and change the proportion.

Edited

0

Avatar fabrice.de.comarmond answered

I understand the role of the background size and I agree it is very usefull but do not understand why the settings changed with widgetkit 2.6.1 . The parallax image didn't change but an effect was added to zoom in on the image with widgetkit 2.6.1. Could you take a look at my sites (both versions of widgetkit are available ?
best regards,
Fabrice

0

Avatar riaz.budree answered

The background size CANNOT be disabled. There has to be something guys, not just open a graphics program.

He is trying to say that it was working fine and now in the upgrade to widgetkit it isn't, this is something a developer could take 5 mins to verify easily between versions.

Is there a minimum image size relative to viewport that is needed for the background-size to be disabled?

0

Avatar fabrice.de.comarmond answered

I have been a Yootheme customer for many years but I still have this issue and since march 30 i am still waiting for maraike or somebody from the support team to get back to me. I do not think I will renew my various developper subscriptions (joomla,worpress,zoo,...) because of the lack of support bewteen two upgrades... One of my customer was very unhappy about this issue and as asked to get reimbursed for a wordpress site developement. I do not think it is reasonable to have such a poor followup on bugs !
Please get back to me as soon as possible...

Best regards,
Fabrice

0

Avatar pixeldiele answered

The wrong background-size is still an unsolved problem / bug. In our case: The parallax window/frame has got the visible size of 1140px x 300px. The vertical offset is set to -200px. So we put a parallax background image with the dimension of 1140px x 550px. The WidgetKit renders an inline zoomed background-size of 1555px x 751px... so the image gets blurry and starts on a wrong position. Some important parts are running out of the frame.

My Workaround is a common custom class for the parallax widgets:

.parallax-class {
background-size: 1140px 550px !important;
}

With this workaround I am able to control parallax frames pixel-perfect. But this should have been done by the widgekit without custom css!

(using WidgetKit 2.9.2 / Joomla 3.6.5)

Edited

0

Avatar mark.s.huber answered

Still unsolved? The code above doesn't seem to make a difference in our case.

Know someone who can answer? Share a link to this question via email or twitter.